use strict;
my $str = '{
\\\\\\"person\\\\\\":{\\\\\\"name\\\\\\":{\\\\\\"firstName\\\\\\":\\\\\\"John\\\\\\",\\\\\\"lastName\\\\\\":\\\\\\"Doe\\\\\\"},\\\\\\"address\\\\\\":{\\\\\\"street\\\\\\":\\\\\\"100 Main Ave\\\\\\",\\\\\\"city\\\\\\":\\\\\\"Redwood City\\\\\\",\\\\\\"usState\\\\\\":\\\\\\"CA\\\\\\",\\\\\\"zipCode\\\\\\":\\\\\\"94061\\\\\\",\\\\\\"country\\\\\\":\\\\\\"United States\\\\\\",\\\\\\"phones\\\\\\":[],\\\\\\"emails\\\\\\":[],\\\\\\"addressLines\\\\\\":[]},\\\\\\"addresses\\\\\\":[],\\\\\\"phones\\\\\\":[{\\\\\\"phoneType\\\\\\":\\\\\\"Home\\\\\\",\\\\\\"phoneNumber\\\\\\":\\\\\\"6500000000\\\\\\"}],\\\\\\"email\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"dateOfBirth\\\\\\":\\\\\\"1900/01/01\\\\\\",\\\\\\"nationalId\\\\\\":\\\\\\"100\\\\\\",\\\\\\"gender\\\\\\":\\\\\\"Male\\\\\\"},\\\\\\"credential\\\\\\":{\\\\\\"userName\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"password\\\\\\":\\\\\\"Password\\\\\\",\\\\\\"securityQuestion\\\\\\":\\\\\\"Name of First Car?\\\\\\",\\\\\\"securityAnswer\\\\\\":\\\\\\"Volvo\\\\\\"}\\""
}';
my $regex = qr/\"email\\\\\\\":\\\\\\\".*?(?=,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}