$re = '/\"email\\\\\\\\\\\\\":\\\\\\\\\\\\\".*?(?=,)/m';
$str = '{
\\\\\\"person\\\\\\":{\\\\\\"name\\\\\\":{\\\\\\"firstName\\\\\\":\\\\\\"John\\\\\\",\\\\\\"lastName\\\\\\":\\\\\\"Doe\\\\\\"},\\\\\\"address\\\\\\":{\\\\\\"street\\\\\\":\\\\\\"100 Main Ave\\\\\\",\\\\\\"city\\\\\\":\\\\\\"Redwood City\\\\\\",\\\\\\"usState\\\\\\":\\\\\\"CA\\\\\\",\\\\\\"zipCode\\\\\\":\\\\\\"94061\\\\\\",\\\\\\"country\\\\\\":\\\\\\"United States\\\\\\",\\\\\\"phones\\\\\\":[],\\\\\\"emails\\\\\\":[],\\\\\\"addressLines\\\\\\":[]},\\\\\\"addresses\\\\\\":[],\\\\\\"phones\\\\\\":[{\\\\\\"phoneType\\\\\\":\\\\\\"Home\\\\\\",\\\\\\"phoneNumber\\\\\\":\\\\\\"6500000000\\\\\\"}],\\\\\\"email\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"dateOfBirth\\\\\\":\\\\\\"1900/01/01\\\\\\",\\\\\\"nationalId\\\\\\":\\\\\\"100\\\\\\",\\\\\\"gender\\\\\\":\\\\\\"Male\\\\\\"},\\\\\\"credential\\\\\\":{\\\\\\"userName\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"password\\\\\\":\\\\\\"Password\\\\\\",\\\\\\"securityQuestion\\\\\\":\\\\\\"Name of First Car?\\\\\\",\\\\\\"securityAnswer\\\\\\":\\\\\\"Volvo\\\\\\"}\\""
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);