#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s{1}|^|\W)(ne)\W"
Local $sString = "ne nado mne" & @CRLF & _
"" & @CRLF & _
"da,mne,horosho" & @CRLF & _
"" & @CRLF & _
"da,ne,horosho" & @CRLF & _
"" & @CRLF & _
"da mne eto nado" & @CRLF & _
"" & @CRLF & _
"hey.mne ne nado" & @CRLF & _
"" & @CRLF & _
"hai eto ploho.neploho" & @CRLF & _
"" & @CRLF & _
"olohon nado mne eto" & @CRLF & _
"eto mne ne nado" & @CRLF & _
"" & @CRLF & _
"fac eto ploho.ne,ploho" & @CRLF & _
"" & @CRLF & _
"da ne nado"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")