$re = '/(\s{1}|^|\W)(ne)\W/m';
$str = 'ne nado mne
da,mne,horosho
da,ne,horosho
da mne eto nado
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
eto mne ne nado
fac eto ploho.ne,ploho
da ne nado';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);