// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s{1}|^|\W)(ne)\W").unwrap();
let string = "ne nado mne
da,mne,horosho
da,ne,horosho
da mne eto nado
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
eto mne ne nado
fac eto ploho.ne,ploho
da ne nado";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}