re = /(\s{1}|^|\W)(ne)\W/m
str = 'ne nado mne
da,mne,horosho
da,ne,horosho
da mne eto nado
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
eto mne ne nado
fac eto ploho.ne,ploho
da ne nado'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end