const regex = /(\s{1}|^|\W)(ne)\W/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s{1}|^|\\W)(ne)\\W', 'gm')
const str = `ne nado mne
da,mne,horosho
da,ne,horosho
da mne eto nado
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
eto mne ne nado
fac eto ploho.ne,ploho
da ne nado`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}