package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s{1}|^|\W)(ne)\W`)
var str = `ne nado mne
da,mne,horosho
da,ne,horosho
da mne eto nado
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
eto mne ne nado
fac eto ploho.ne,ploho
da ne nado`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}