using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\+\d )(?<!\+\d{2} )(?<!\+\d{3} )\b\d{9}\b";
string input = @"The number is +31 713176319 and 650068168 is another one.
+1 713176319
+971 713176319";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}