import re
regex = re.compile(r"(?<!\+\d )(?<!\+\d{2} )(?<!\+\d{3} )\b\d{9}\b", flags=re.MULTILINE)
test_str = ("The number is +31 713176319 and 650068168 is another one.\n\n"
"+1 713176319\n"
"+971 713176319")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")