const regex = new RegExp('(?<!\\+\\d )(?<!\\+\\d{2} )(?<!\\+\\d{3} )\\b\\d{9}\\b', 'gm')
const str = `The number is +31 713176319 and 650068168 is another one.
+1 713176319
+971 713176319`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}