$re = '/(?<!\+\d )(?<!\+\d{2} )(?<!\+\d{3} )\b\d{9}\b/m';
$str = 'The number is +31 713176319 and 650068168 is another one.
+1 713176319
+971 713176319';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);