re = /(?<!\+\d )(?<!\+\d{2} )(?<!\+\d{3} )\b\d{9}\b/m
str = 'The number is +31 713176319 and 650068168 is another one.
+1 713176319
+971 713176319'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end