const regex = /(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\\\/p>)', 'g')
const str = `<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>`;
const subst = `$0 <img src="imagem.jpg">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);