$re = '/(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)/';
$str = '<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>';
$subst = "$0 <img src=\"imagem.jpg\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;