import re
regex = re.compile(r"(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)")
test_str = ("<p>Some text 1</p>\n"
"<p>Some text 2</p>\n"
"<p>Some text 3</p>")
subst = "$0 <img src=\"imagem.jpg\">"
result = regex.sub(subst, test_str)
if result:
print(result)