re = /(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)/
str = '<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>'
subst = '$0 <img src="imagem.jpg">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result