# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\\/p>)\s?){3}/$0\n\t<img src="imagem.jpg">/g;t' <<< "<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>"