import Foundation
let pattern = #"((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)\s?){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\n\t<img src="imagem.jpg">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)