import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\\/p>)\\s?){3}";
final String string = "<p>Some text 1</p>\n"
+ "<p>Some text 2</p>\n"
+ "<p>Some text 3</p>";
final String subst = "$0\\n\\t<img src=\"imagem.jpg\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}