using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)\s?){3}";
string substitution = @"$0\n\t<img src=""imagem.jpg"">";
string input = @"<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}