const regex = /((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)\s?){3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\\\/p>)\\s?){3}', 'g')
const str = `<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>`;
const subst = `$0\n\t<img src="imagem.jpg">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);