using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}";
string input = @"un gars une fille s01 ep05 chez psy 01.avi
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}