// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}").unwrap();
let string = "un gars une fille s01 ep05 chez psy 01.avi
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}