$re = '/[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}/';
$str = 'un gars une fille s01 ep05 chez psy 01.avi
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);