package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}`)
var str = `un gars une fille s01 ep05 chez psy 01.avi
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}