re = /[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}/
str = 'un gars une fille s01 ep05 chez psy 01.avi
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end