using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=\""product-name\"".*<a\shref=\""(.*?)\""";
string input = @"<h2 class=""product-name""><a href=""erkek-ayakkabi-spor-gri-17sfd3007141340-p"" title=""..."">...</a></h2>\r\n
<h2 class=""test-name""><a href=""erkek-ayakkabi-spor-gri-17sfd3007141340-p"" title=""..."">...</a></h2>\r\n
<h2 class=""product-name""><a href=""erkek-ayakkabi-spor-gri-17sfd3007141340-p"" title=""..."">...</a></h2>\r\n";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}