re = /class=\"product-name\".*<a\shref=\"(.*?)\"/
str = '<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="test-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end