import Foundation
let pattern = #"class=\"product-name\".*<a\shref=\"(.*?)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n
<h2 class="test-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)