use strict;
my $str = '<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="test-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n';
my $regex = qr/class=\"product-name\".*<a\shref=\"(.*?)\"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}