package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`class=\"product-name\".*<a\shref=\"(.*?)\"`)
var str = `<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n
<h2 class="test-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\r\n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}