$re = '/class=\"product-name\".*<a\shref=\"(.*?)\"/';
$str = '<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="test-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n
<h2 class="product-name"><a href="erkek-ayakkabi-spor-gri-17sfd3007141340-p" title="...">...</a></h2>\\r\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);