import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Guatemala, ([A-Z]+) (\\d+) (de) (.+) (de) (\\d+)$";
final String string = "ERO 65\n"
+ "23\n"
+ "(279248-2)–7–julio\n"
+ "(279249-2)–7–julio\n"
+ "(VSN-0973)–7–julio\n"
+ "(279269-2)–7–julio\n\n"
+ "24\n"
+ "Guatemala, VIERNES 7 de julio de 2023\n"
+ "NÚMERO 65\n"
+ "DIARIO de CENTRO AMÉRICA\n"
+ "(279246-2)–7–julio\n"
+ "(279214-2)–7–julio";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}