const regex = /^Guatemala, ([A-Z]+) (\d+) (de) (.+) (de) (\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Guatemala, ([A-Z]+) (\\d+) (de) (.+) (de) (\\d+)$', 'gm')
const str = `ERO 65
23
(279248-2)–7–julio
(279249-2)–7–julio
(VSN-0973)–7–julio
(279269-2)–7–julio
24
Guatemala, VIERNES 7 de julio de 2023
NÚMERO 65
DIARIO de CENTRO AMÉRICA
(279246-2)–7–julio
(279214-2)–7–julio`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}