re = /^Guatemala, ([A-Z]+) (\d+) (de) (.+) (de) (\d+)$/m
str = 'ERO 65
23
(279248-2)–7–julio
(279249-2)–7–julio
(VSN-0973)–7–julio
(279269-2)–7–julio
24
Guatemala, VIERNES 7 de julio de 2023
NÚMERO 65
DIARIO de CENTRO AMÉRICA
(279246-2)–7–julio
(279214-2)–7–julio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end