import re
regex = re.compile(r"^Guatemala, ([A-Z]+) (\d+) (de) (.+) (de) (\d+)$", flags=re.MULTILINE)
test_str = ("ERO 65\n"
"23\n"
"(279248-2)–7–julio\n"
"(279249-2)–7–julio\n"
"(VSN-0973)–7–julio\n"
"(279269-2)–7–julio\n\n"
"24\n"
"Guatemala, VIERNES 7 de julio de 2023\n"
"NÚMERO 65\n"
"DIARIO de CENTRO AMÉRICA\n"
"(279246-2)–7–julio\n"
"(279214-2)–7–julio")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")