#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Hello.*world"
Local $sString = "my Hello world. This is mongo" & @CRLF & _
"hh Hello. This is mongo world" & @CRLF & _
"world. This is mongo Hello" & @CRLF & _
"Hello world" & @CRLF & _
"world Hello" & @CRLF & _
"world hello" & @CRLF & _
"hello world"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")