// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Hello.*world").unwrap();
let string = "my Hello world. This is mongo
hh Hello. This is mongo world
world. This is mongo Hello
Hello world
world Hello
world hello
hello world";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}