import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Hello.*world";
final String string = "my Hello world. This is mongo\n"
+ "hh Hello. This is mongo world\n"
+ "world. This is mongo Hello\n"
+ "Hello world\n"
+ "world Hello\n"
+ "world hello\n"
+ "hello world";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}