using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello.*world";
string input = @"my Hello world. This is mongo
hh Hello. This is mongo world
world. This is mongo Hello
Hello world
world Hello
world hello
hello world";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}