const regex = /Hello.*world/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Hello.*world', 'gm')
const str = `my Hello world. This is mongo
hh Hello. This is mongo world
world. This is mongo Hello
Hello world
world Hello
world hello
hello world`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}