using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)";
string substitution = @"\2 <> \3\n";
string input = @"FF_SF_FIRE_STRATEGY_G SOMETHING-ELSE";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}