$re = '/(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)/m';
$str = 'FF_SF_FIRE_STRATEGY_G SOMETHING-ELSE';
$subst = "\2 <> \3\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;