const regex = /(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)', 'gm')
const str = `FF_SF_FIRE_STRATEGY_G SOMETHING-ELSE`;
const subst = `\2 <> \3\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);