import Foundation
let pattern = #"(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"FF_SF_FIRE_STRATEGY_G SOMETHING-ELSE"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 <> \3\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)