import re
regex = re.compile(r"(^|[[:blank:]])([^[:blank:]]*)_([^[:blank:]_]*)([[:blank:]]|$)", flags=re.MULTILINE)
test_str = "FF_SF_FIRE_STRATEGY_G SOMETHING-ELSE"
subst = "\\2 <> \\3\\n"
result = regex.sub(subst, test_str)
if result:
print(result)