#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=[a-z0-9\/]*\d)(?<=[^:.-]\b)[\w\/]+(?=\b[^:.-])"
Local $sString = "aaaaaaa bbb ccc dddddd A1/002, A/1002" & @CRLF & _
"A123, B123J, C1234JB, D2345JC" & @CRLF & _
"xxxx A123" & @CRLF & _
"B456 bbbbb bbbb ,b bbbb" & @CRLF & _
"12" & @CRLF & _
"23" & @CRLF & _
"24" & @CRLF & _
"55, 66, 77, 88" & @CRLF & _
"Xxxxx 55" & @CRLF & _
"66 yyyyy" & @CRLF & _
"aaa bbb ccc ddd" & @CRLF & _
"eeeeee fff gggggg" & @CRLF & _
"hhh ii jjjjj kkkkk" & @CRLF & _
"2011-11-11 11:11:11.000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")