import re
regex = re.compile(r"(?=[a-z0-9\/]*\d)(?<=[^:.-]\b)[\w\/]+(?=\b[^:.-])", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("aaaaaaa bbb ccc dddddd A1/002, A/1002\n"
"A123, B123J, C1234JB, D2345JC\n"
"xxxx A123\n"
"B456 bbbbb bbbb ,b bbbb\n"
"12\n"
"23\n"
"24\n"
"55, 66, 77, 88\n"
"Xxxxx 55\n"
"66 yyyyy\n"
"aaa bbb ccc ddd\n"
"eeeeee fff gggggg\n"
"hhh ii jjjjj kkkkk\n"
"2011-11-11 11:11:11.000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")