using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[a-z0-9\/]*\d)(?<=[^:.-]\b)[\w\/]+(?=\b[^:.-])";
string input = @"aaaaaaa bbb ccc dddddd A1/002, A/1002
A123, B123J, C1234JB, D2345JC
xxxx A123
B456 bbbbb bbbb ,b bbbb
12
23
24
55, 66, 77, 88
Xxxxx 55
66 yyyyy
aaa bbb ccc ddd
eeeeee fff gggggg
hhh ii jjjjj kkkkk
2011-11-11 11:11:11.000
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}